现象

ESXI更新到6.7之后,vcenter控制台会默认有如下提示

esx.problem.hyperthreading.unmitigated

打开ESXI控制台,提示如下

该主机可能容易受到 CVE-2018-3646 中所描述问题的影响,有关详细信息和 VMware 建议,请参阅 https://kb.vmware.com/s/article/55636。

原因

VMware 在更新VMSA-2018-0020后新增了一个针对CVE-2018-3646漏洞修复状态的提示,如果此漏洞未修复,则会有如上的提示。

关于CVE-2018-3646

CVE-2018-3646主要是intel处理器芯片级的漏洞,可能造成虚拟化层面的信息泄露,具体可参看intel官方的公告
https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00161.html

vmware官方说明如下

https://kb.vmware.com/s/article/55806

https://kb.vmware.com/s/article/57374

禁用此提示方法

由于此漏洞属于芯片级漏洞,更新固件会造成较大的性能损失,在私有云环境下,此漏洞的影响范围可控,我们可以选择禁用此提示,暂缓漏洞的修复

禁用的方法如下:

  • 在vcenter中选中ESXI主机,打开配置>高级系统设置
  • 点击编辑,筛选UserVars.SuppressHyperthreadWarning
  • UserVars.SuppressHyperthreadWarning的值由0改为1

更改实时生效,不需要重启之类的操作

最后修改:2019 年 01 月 08 日 10 : 40 AM
如果觉得我的文章对你有用,请随意赞赏